Announcements

Help us improve the Equinix Community by completing a quick survey

Discussions

Getting "Non-Deprovisioned" Connections

Getting "Non-Deprovisioned" Connections

API_User
Level 9

I created the following query filter to use with the https://api.equinix.com/fabric/v4/connections/search API to retrieve all "non-deprovisioned" connections:

{
    "filter": {
        "AND": [
            {
                "property": "/operation/equinixStatus",
                "operator": "=",
                "values": [
                    "PENDING_APPROVAL",
                    "PROVISIONING",
                    "PROVISIONED",
                    "NOT_PROVISIONED",
                    "REJECTED",
                    "PENDING_BGP_PEERING"
                ]
            },
            {
                "property": "/aSide/accessPoint/location/metroCode",
                "operator": "=",
                "values": [
                    "SV"
                ]
            }
        ]
    },
    "pagination": {
        "limit": 3000,
        "offset": 0
    },
    "sort": [
        {
            "property": "/name",
            "direction": "DESC"
        }
    ]
}

The results of the above query returned multiple connections that had an equinixStatus of DEPROVISIONED.

Is there an error in the above query filter as I can't see why there would be any connections returned with an equinixStatus of a value other than one in the above list of values specified in the filter?

I even simplified the values array to only include PROVISIONED and still got results containing DEPROVISIONED.

Replies 3 3

API_User
Level 9
Here is the equivalent v3 API to get the same information which works as expected.
https://api.equinix.com/ecx/v3/l2/buyer/connections?status=PENDING_APPROVAL,PROVISIONING,PROVISIONED...
What is the expected response time on messages left on this forum as if this is the primary means of submitting API questions the response times have been very slow.

API_User
Level 9
Thanks for reaching out. Could you please try with lowercase "and" in the filter as suggested in the documentation and let us know the result while we are investigating your case?

Thanks,
Equinix Fabric Engineering Team

API_User
Level 9
Thanks! That resolved the issue. Glad it was something simple.